You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
Amanda Cameron feb8aeea1c [skip ci] Add .gitignore 9 months ago
.drone.yml ci: Drop darwin/amd64 9 months ago
.envrc first-run: Initial commit of first-run flow. 9 months ago
.gitignore [skip ci] Add .gitignore 9 months ago
LICENSE Add README/LICENSE 11 months ago
README.md [skip ci] readme: More clarification, formatting changes. 9 months ago
first-run.go first-run: Use new get_mod_info endpoint. 9 months ago
go.mod first-run: Initial commit of first-run flow. 9 months ago
go.sum first-run: Initial commit of first-run flow. 9 months ago
main.go main: Better download failure detection. 9 months ago
types.go first-run: Use new get_mod_info endpoint. 9 months ago
updater.go updater: gofmt 9 months ago

README.md

Amanda's Updater for Forecaster's Modpack manager

To use this, download from The Releases Page and place it in the MultiMC instance, then set it as a pre-launch command.

This is heavily based off Lizzy's Python Updater -- but written in Go. It supports the same config.json as Lizzy's does, but with an additional value of pack_url for the base URL of the pack to download.

Build Instructions

This is a program written in Go, and requires an up-to-date go compiler.

Linux (Ubuntu)

You will need the additional libraries installed to build this program:

apt-get install libgles2-mesa libgles2-mesa-dev libwayland-dev libxkbcommon-dev libxkbcommon-x11-dev libx11-dev

Then you just need to run go build .

MacOS

In theory, nothing extra is needed, just a go build . will work.

Windows

I'm not entirely sure what will be needed for windows, however a nieve cross-compile works, so just running go build . should also work for windows.

License

See the relevent file